cLoadPatternsGetAutoSeismicCode Method

Retrieves the code name used for auto seismic parameters in Quake-type load patterns.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetAutoSeismicCode(
	string Name,
	ref string CodeName
)

Parameters

Name
Type: SystemString
The name of an existing Quake-type load pattern.
CodeName
Type: SystemString
This is either blank or the name code used for the auto seismic parameters. Blank means no auto seismic load is specified for the Quake-type load pattern.

Return Value

Type: Int32
Returns zero if the code is successfully retrieved; otherwise it returns a nonzero value.
Remarks
An error is returned if the specified load pattern is not a Quake-type load pattern.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim CodeName As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add new load pattern
       ret = SapModel.LoadPatterns.Add("EQX", LTYPE_QUAKE)

   'assign BOCA96 parameters
       ret = SapModel.LoadPatterns.AutoSeismic.SetBOCA96("EQX", 1, 0.05, 1, 0.035, 0, False, 0, 0, 0.4, 0.4, 1.5, 8)

   'get auto seismic code
       ret = SapModel.LoadPatterns.GetAutoSeismicCode("EQX", CodeName)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also