cPointObjSetLoadForce Method

Makes point force load assignments to point objects.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetLoadForce(
	string Name,
	string LoadPat,
	ref double[] Value,
	bool Replace = false,
	string CSys = "Global",
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing point object or group depending on the value of the ItemType item.
LoadPat
Type: SystemString
The name of the load pattern for the point force load.
Value
Type: SystemDouble
This is an array of six point load values.
  • Value(0) = F1 [F]
  • Value(1) = F2 [F]
  • Value(2) = F3 [F]
  • Value(3) = M1 [FL]
  • Value(4) = M2 [FL]
  • Value(5) = M3 [FL]
Replace (Optional)
Type: SystemBoolean
If this item is True, all previous point force loads, if any, assigned to the specified point object(s) in the specified load pattern are deleted before making the new assignment.
CSys (Optional)
Type: SystemString
The name of the coordinate system for the considered point force load. This is Local or the name of a defined coordinate system.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the load assignment is made to the point object specified by the Name item.

If this item is Group, the load assignment is made to all point objects in the group specified by the Name item.

If this item is SelectedObjects, the load assignment is made to all selected point objects and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the load assignments are successfully made, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim Value as Double()

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

   'add point load
       Redim Value(5)
       Value(0) = 10
       ret = SapModel.PointObj.SetLoadForce("2", "DEAD", Value)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also