cPropFrameGetChannel Method |
Namespace: ETABS2016
int GetChannel( string Name, ref string FileName, ref string MatProp, ref double T3, ref double T2, ref double Tf, ref double Tw, ref int Color, ref string Notes, ref string GUID )
Public Sub Example() Dim SapModel As cSapModel Dim EtabsObject As cOAPI Dim ret As Integer = -1 Dim Name As String Dim FileName As String Dim MatProp As String Dim t3 As Double Dim t2 As Double Dim tf As Double Dim tw As Double Dim Color As Integer Dim Notes As String Dim GUID As String 'create ETABS object EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject") 'start ETABS application ret = EtabsObject.ApplicationStart() 'create SapModel object SapModel = EtabsObject.SapModel 'initialize model ret = SapModel.InitializeNewModel() 'create steel deck template model ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24) 'set new frame section property ret = SapModel.PropFrame.SetChannel("CHN1", "A992Fy50", 24, 6, 0.5, 0.3) 'get frame section property data ret = SapModel.PropFrame.GetChannel("CHN1", FileName, MatProp, t3, t2, tf, tw, Color, Notes, GUID) 'close ETABS EtabsObject.ApplicationExit(False) 'clean up variables SapModel = Nothing EtabsObject = Nothing End Sub