cFrameObjGetColumnSpliceOverwrite Method |
Retrieves the frame object column splice overwrite assignment.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetColumnSpliceOverwrite(
string Name,
ref int SpliceOption,
ref double Height
)
Function GetColumnSpliceOverwrite (
Name As String,
ByRef SpliceOption As Integer,
ByRef Height As Double
) As Integer
int GetColumnSpliceOverwrite(
String^ Name,
int% SpliceOption,
double% Height
)
abstract GetColumnSpliceOverwrite :
Name : string *
SpliceOption : int byref *
Height : float byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object.
- SpliceOption
- Type: SystemInt32
This is a numeric value from 1 to 3 that specifies the option used for defining the splice overwrite.
- from story data (default)
- no splice
- splice at height above story at bottom of the column object
- Height
- Type: SystemDouble
If the SpliceOption=3, this specifies the height of the splice above the story at the bottom of the column object.
Return Value
Type:
Int32
Returns zero if the column splice overwrite data is successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetColumnSpliceOverwrite("15", 2, 0)
Dim SpliceOption As Integer
Dim Height As Double
ret = SapModel.FrameObj.GetColumnSpliceOverwrite("15", SpliceOption, Height)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also