cAnalysisResultsStoryDrifts Method |
Reports the story drifts
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint StoryDrifts(
ref int NumberResults,
ref string[] Story,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref string[] Direction,
ref double[] Drift,
ref string[] Label,
ref double[] X,
ref double[] Y,
ref double[] Z
)
Function StoryDrifts (
ByRef NumberResults As Integer,
ByRef Story As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef Direction As String(),
ByRef Drift As Double(),
ByRef Label As String(),
ByRef X As Double(),
ByRef Y As Double(),
ByRef Z As Double()
) As Integer
int StoryDrifts(
int% NumberResults,
array<String^>^% Story,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<String^>^% Direction,
array<double>^% Drift,
array<String^>^% Label,
array<double>^% X,
array<double>^% Y,
array<double>^% Z
)
abstract StoryDrifts :
NumberResults : int byref *
Story : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
Direction : string[] byref *
Drift : float[] byref *
Label : string[] byref *
X : float[] byref *
Y : float[] byref *
Z : float[] byref -> int
Parameters
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- Story
- Type: SystemString
This is an array of the story levels for each result
- LoadCase
- Type: SystemString
This is an array of the names of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array of the step types, if any, for each result
- StepNum
- Type: SystemDouble
This is an array of the step numbers, if any, for each result
- Direction
- Type: SystemString
This is an array of the directions of the Drift values
- Drift
- Type: SystemDouble
This is an array of the drift values
- Label
- Type: SystemString
This is an array of the point labels for each result
- X
- Type: SystemDouble
This is an array of the displacements in the X direction [L]
- Y
- Type: SystemDouble
This is an array of the displacements in the Y direction [L]
- Z
- Type: SystemDouble
This is an array of the displacements in the Z direction [L]
Return Value
Type:
Int32
Returns zero if the results are successfully recovered, otherwise it returns a nonzero value
Remarks
See Also