cLoadPatternsDelete Method

Deletes the specified load pattern.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int Delete(
	string Name
)

Parameters

Name
Type: SystemString
The name of an existing load pattern.

Return Value

Type: Int32
Returns zero if the load pattern is successfully deleted, otherwise it returns a nonzero value.
Remarks
The load pattern is not deleted and the function returns an error if the load pattern is assigned to an load case or if it is the only defined load pattern.
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'delete load case
       ret = SapModel.LoadPatterns.Delete("DEAD")

   'Note:  ret in the above line returns 1, indicating an error.
   'This is because the load pattern DEAD is assigned to 
   'load case DEAD.

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also