cPropFrameSetCoverPlatedI Method |
Initializes a cover plated I-type frame section property. If this function is called for an
existing frame section property, all items for the section are reset to their default value.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetCoverPlatedI(
string Name,
string SectName,
double FyTopFlange,
double FyWeb,
double FyBotFlange,
double Tc,
double Bc,
string MatPropTop,
double Tcb,
double Bcb,
string MatPropBot,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetCoverPlatedI (
Name As String,
SectName As String,
FyTopFlange As Double,
FyWeb As Double,
FyBotFlange As Double,
Tc As Double,
Bc As Double,
MatPropTop As String,
Tcb As Double,
Bcb As Double,
MatPropBot As String,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetCoverPlatedI(
String^ Name,
String^ SectName,
double FyTopFlange,
double FyWeb,
double FyBotFlange,
double Tc,
double Bc,
String^ MatPropTop,
double Tcb,
double Bcb,
String^ MatPropBot,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetCoverPlatedI :
Name : string *
SectName : string *
FyTopFlange : float *
FyWeb : float *
FyBotFlange : float *
Tc : float *
Bc : float *
MatPropTop : string *
Tcb : float *
Bcb : float *
MatPropBot : string *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new frame section property.
If this is an existing property, that property is modified; otherwise, a new property is added. - SectName
- Type: SystemString
- FyTopFlange
- Type: SystemDouble
The yield strength of the top flange of the I-section. [F/L2]
If this item is 0, the yield strength of the I-section specified by the
SectName item is used.
- FyWeb
- Type: SystemDouble
The yield strength of the web of the I-section. [F/L2]
If this item is 0, the yield strength of the I-section specified by the
SectName item is used.
- FyBotFlange
- Type: SystemDouble
The yield strength of the bottom flange of the I-section. [F/L2]
If this item is 0, the yield strength of the I-section specified by the
SectName item is used.
- Tc
- Type: SystemDouble
- Bc
- Type: SystemDouble
- MatPropTop
- Type: SystemString
The name of the material property for the bottom cover plate.
This item applies only if both the tcb and the
bcb items are greater than 0.
- Tcb
- Type: SystemDouble
- Bcb
- Type: SystemDouble
- MatPropBot
- Type: SystemString
The name of the material property for the bottom cover plate.
This item applies only if both the tcb and
the bcb items are greater than 0.
- Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.
If this item is input as Default, the program assigns a GUID to the section.
Return Value
Type:
Int32Returns zero if the section property is successfully initialized;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropFrame.SetISection("ISEC", "A992Fy50", 24, 8, 0.5, 0.3, 8, 0.5)
ret = SapModel.PropFrame.SetCoverPlatedI("CPI1", "ISEC", 0, 36, 0, 0.75, 14, "A992Fy50", 0.5, 6, "A992Fy50")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also