cAnalysisResultsModalParticipationFactors Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint ModalParticipationFactors(
ref int NumberResults,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] Period,
ref double[] UX,
ref double[] UY,
ref double[] UZ,
ref double[] RX,
ref double[] RY,
ref double[] RZ,
ref double[] ModalMass,
ref double[] ModalStiff
)
Function ModalParticipationFactors (
ByRef NumberResults As Integer,
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef Period As Double(),
ByRef UX As Double(),
ByRef UY As Double(),
ByRef UZ As Double(),
ByRef RX As Double(),
ByRef RY As Double(),
ByRef RZ As Double(),
ByRef ModalMass As Double(),
ByRef ModalStiff As Double()
) As Integer
int ModalParticipationFactors(
int% NumberResults,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% Period,
array<double>^% UX,
array<double>^% UY,
array<double>^% UZ,
array<double>^% RX,
array<double>^% RY,
array<double>^% RZ,
array<double>^% ModalMass,
array<double>^% ModalStiff
)
abstract ModalParticipationFactors :
NumberResults : int byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
Period : float[] byref *
UX : float[] byref *
UY : float[] byref *
UZ : float[] byref *
RX : float[] byref *
RY : float[] byref *
RZ : float[] byref *
ModalMass : float[] byref *
ModalStiff : float[] byref -> int
Parameters
- NumberResults
- Type: SystemInt32
- LoadCase
- Type: SystemString
- StepType
- Type: SystemString
- StepNum
- Type: SystemDouble
- Period
- Type: SystemDouble
- UX
- Type: SystemDouble
- UY
- Type: SystemDouble
- UZ
- Type: SystemDouble
- RX
- Type: SystemDouble
- RY
- Type: SystemDouble
- RZ
- Type: SystemDouble
- ModalMass
- Type: SystemDouble
- ModalStiff
- Type: SystemDouble
Return Value
Type:
Int32
See Also