cPropFrameGetPropFileNameList Method

Retrieves the names of all defined frame section properties of a specified type in a specified frame section property file.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetPropFileNameList(
	string FileName,
	ref int NumberNames,
	ref string[] MyName,
	ref eFramePropType[] MyPropType,
	eFramePropType PropType = 
)

Parameters

FileName
Type: SystemString
The name of the frame section property file from which to get the name list.

In most cases, inputting only the name of the property file (e.g. Sections8.pro) is required, and the program will be able to find it. In some cases, inputting the full path to the property file may be necessary.

NumberNames
Type: SystemInt32
The number of frame section property names retrieved by the program.
MyName
Type: SystemString
This is an array the includes the property names obtained from the frame section property file.
MyPropType
Type: ETABS2016eFramePropType
This is an array the includes the property type for each property obtained from the frame section property file.
PropType (Optional)
Type: ETABS2016eFramePropType
This optional value is one of the items in the eFramePropType enumeration.

If no value is input for PropType, names are returned for all frame section properties in the specified file regardless of type.

Return Value

Type: Int32
Returns zero if the names are successfully retrieved; otherwise it returns a nonzero value
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim NumberNames As Integer
       Dim MyName() As String
       Dim MyPropType() As eFramePropType

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'get frame section property names
       ret = SapModel.PropFrame.GetPropFileNameList("Sections8.pro", NumberNames, MyName, MyPropType, eFramePropType.I)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also