Initializes a slab property.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int SetSlab(
string Name,
eSlabType SlabType,
eShellType ShellType,
string MatProp,
double Thickness,
int color = -1,
string notes = "",
string GUID = ""
)
Function SetSlab ( _
Name As String, _
SlabType As eSlabType, _
ShellType As eShellType, _
MatProp As String, _
Thickness As Double, _
Optional color As Integer = -1, _
Optional notes As String = "", _
Optional GUID As String = "" _
) As Integer
int SetSlab(
String^ Name,
eSlabType SlabType,
eShellType ShellType,
String^ MatProp,
double Thickness,
int color = -1,
String^ notes = L"",
String^ GUID = L""
)
Parameters
- Name
- Type:
System String
The name of a slab property. If this is an existing property,
that property is modified; otherwise, a new property is added.
- SlabType
- Type: ETABS2015 eSlabType
This is one of the items in the eSlabType enumeration.
If this item is Ribbed, use the GetSlabRibbed(String, Double , Double , Double , Double , Double , Int32 )
function to get additional parameters.
If this item is Waffle, use the GetSlabWaffle(String, Double , Double , Double , Double , Double , Double )
function to get additional parameters.
- ShellType
- Type: ETABS2015 eShellType
This is one of the items in the eShellType enumeration.
- MatProp
- Type:
System String
The name of the material property for the area property.
This item does not apply when ShellType is Layered.
- Thickness
- Type:
System Double
The membrane thickness. [L]
This item does not apply when ShellType is Layered.
- color (Optional)
- Type:
System Int32
The display color assigned to the property.
- notes (Optional)
- Type:
System String
The notes, if any, assigned to the property.
- GUID (Optional)
- Type:
System String
The GUID (global unique identifier), if any, assigned to the property.
Return Value
Returns zero if the property is successfully initialized;
otherwise it returns a nonzero value.
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim SlabType As ETABS2013.eSlabType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetSlab("MyShellProp1A", ETABS2013.eSlabType.Drop, ETABS2013.eShellType.ShellThin, "4000Psi", 14.2)
ret = SapModel.PropArea.GetSlab("MyShellProp1A", SlabType, ShellType, MatProp, Thickness, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Public Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim SlabType As ETABS2013.eSlabType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'set new area property
ret = SapModel.PropArea.SetSlab("MyShellProp1A", ETABS2013.eSlabType.Drop, ETABS2013.eShellType.ShellThin, "4000Psi", 14.2)
'get area property data
ret = SapModel.PropArea.GetSlab("MyShellProp1A", SlabType, ShellType, MatProp, Thickness, Color, Notes, GUID)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub