cPropAreaSetDeckSolidSlab Method

Initializes a solid-slab deck property

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetDeckSolidSlab(
	string Name,
	double SlabDepth,
	double ShearStudDia,
	double ShearStudHt,
	double ShearStudFu
)

Parameters

Name
Type: SystemString
The name of an existing deck property created with the SetDeck(String, eDeckType, eShellType, String, Double, Int32, String, String) function.
SlabDepth
Type: SystemDouble
Slab Depth, tc
ShearStudDia
Type: SystemDouble
Shear Stud Diameter
ShearStudHt
Type: SystemDouble
Shear Stud Height, hs
ShearStudFu
Type: SystemDouble
Shear Stud Tensile Strength, Fu

Return Value

Type: Int32
Returns zero if the property is successfully initialized; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DeckType As eDeckType
       Dim ShellType As eShellType
       Dim MatProp As String
       Dim Thickness As Double
       Dim Color As Integer
       Dim Notes As String
       Dim GUID As String
       Dim SlabDepth As Double
       Dim ShearStudDia As Double
       Dim ShearStudHt As Double
       Dim ShearStudFu As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new area property
       ret = SapModel.PropArea.SetDeck("MyShellProp1A", eDeckType.SolidSlab, eShellType.ShellThin, "4000Psi", 14)

   'set new area property
       ret = SapModel.PropArea.SetDeckSolidSlab(Name:="MyShellProp1A", SlabDepth:=3.5, ShearStudDia:=0.75, ShearStudHt:=6, ShearStudFu:=65000)

   'get area property data
       ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)

   'get area property data
       ret = SapModel.PropArea.GetDeckSolidSlab("MyShellProp1A", SlabDepth, ShearStudDia, ShearStudHt, ShearStudFu)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also