cPropAreaSetDeck Method

Initializes a deck property.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetDeck(
	string Name,
	eDeckType DeckType,
	eShellType ShellType,
	string MatProp,
	double Thickness,
	int color = -1,
	string notes = "",
	string GUID = ""
)

Parameters

Name
Type: SystemString
The name of a deck property. If this is an existing property, that property is modified; otherwise, a new property is added.
DeckType
Type: ETABS2016eDeckType
This is one of the following items in the eDeckType enumeration.

If this item is Filled, use the SetDeckFilled(String, Double, Double, Double, Double, Double, Double, Double, Double, Double, Double) function to get additional parameters.

If this item is Unfilled, use the SetDeckUnfilled(String, Double, Double, Double, Double, Double, Double) function to get additional parameters.

If this item is SolidSlab, use the SetDeckSolidSlab(String, Double, Double, Double, Double) function to get additional parameters.

ShellType
Type: ETABS2016eShellType
This is one of the items in the eShellType enumeration.

Please note that for deck properties, this is always Membrane

MatProp
Type: SystemString
The name of the material property for the area property.

This item does not apply when ShellType = 6.

Thickness
Type: SystemDouble
The membrane thickness. [L]

This item does not apply when ShellType = 6.

color (Optional)
Type: SystemInt32
The display color assigned to the property.
notes (Optional)
Type: SystemString
The notes, if any, assigned to the property.
GUID (Optional)
Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.

Return Value

Type: Int32
Returns zero if the property is successfully initialized; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim DeckType As eDeckType
       Dim ShellType As eShellType
       Dim MatProp As String
       Dim Thickness As Double
       Dim Color As Integer
       Dim Notes As String
       Dim GUID As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

    'set new area property
       ret = SapModel.PropArea.SetDeck("MyShellProp1A", eDeckType.Filled, eShellType.ShellThin, "4000Psi", 14)

    'get area property data
       ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also