cPropAreaGetSlab Method

Retrieves property data for a slab section.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetSlab(
	string Name,
	ref eSlabType SlabType,
	ref eShellType ShellType,
	ref string MatProp,
	ref double Thickness,
	ref int color,
	ref string notes,
	ref string GUID
)

Parameters

Name
Type: SystemString
The name of an existing slab property.
SlabType
Type: ETABS2016eSlabType
This is one of the items in the eSlabType enumeration.

If this item is Ribbed, use the GetSlabRibbed(String, Double, Double, Double, Double, Double, Int32) function to get additional parameters.

If this item is Waffle, use the GetSlabWaffle(String, Double, Double, Double, Double, Double, Double) function to get additional parameters.

ShellType
Type: ETABS2016eShellType
This is one of the items in the eShellType enumeration.
MatProp
Type: SystemString
The name of the material property for the area property.

This item does not apply when ShellType is Layered.

Thickness
Type: SystemDouble
The membrane thickness. [L]

This item does not apply when ShellType is Layered.

color
Type: SystemInt32
The display color assigned to the property.
notes
Type: SystemString
The notes, if any, assigned to the property.
GUID
Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.

Return Value

Type: Int32
The function returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim SlabType As eSlabType
       Dim ShellType As eShellType
       Dim MatProp As String
       Dim Thickness As Double
       Dim Color As Integer
       Dim Notes As String
       Dim GUID As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

    'set new area property
       ret = SapModel.PropArea.SetSlab("MyShellProp1A", eSlabType.Drop, eShellType.ShellThin, "4000Psi", 14.2)

    'get area property data
       ret = SapModel.PropArea.GetSlab("MyShellProp1A", SlabType, ShellType, MatProp, Thickness, Color, Notes, GUID)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also