cPropAreaSetDeckFilled Method |
Namespace: ETABS2016
int SetDeckFilled( string Name, double SlabDepth, double RibDepth, double RibWidthTop, double RibWidthBot, double RibSpacing, double ShearThickness, double UnitWeight, double ShearStudDia, double ShearStudHt, double ShearStudFu )
Public Sub Example() Dim SapModel As cSapModel Dim EtabsObject As cOAPI Dim ret As Integer = -1 Dim DeckType As eDeckType Dim ShellType As eShellType Dim MatProp As String Dim Thickness As Double Dim Color As Integer Dim Notes As String Dim GUID As String Dim SlabDepth As Double Dim RibDepth As Double Dim RibWidthTop As Double Dim RibWidthBot As Double Dim RibSpacing As Double Dim DeckShearThickness As Double Dim DeckUnitWeight As Double Dim ShearStudDia As Double Dim ShearStudHt As Double Dim ShearStudFu As Double 'create ETABS object EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject") 'start ETABS application ret = EtabsObject.ApplicationStart() 'create SapModel object SapModel = EtabsObject.SapModel 'initialize model ret = SapModel.InitializeNewModel() 'create steel deck template model ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24) 'set new area property ret = SapModel.PropArea.SetDeck("MyShellProp1A", eDeckType.Filled, eShellType.ShellThin, "4000Psi", 14) 'set new area property ret = SapModel.PropArea.SetDeckFilled(Name:="MyShellProp1A", SlabDepth:=15.6, RibDepth:=1.1, RibWidthTop:=2.3, RibWidthBot:=2.4, _ RibSpacing:=7, ShearThickness:=5, UnitWeight:=3.1, ShearStudDia:=1.02, ShearStudHt:=4.4, ShearStudFu:=2.01) 'get area property data ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID) 'get area property data ret = SapModel.PropArea.GetDeckFilled("MyShellProp1A", SlabDepth, RibDepth, RibWidthTop, RibWidthBot, _ RibSpacing, DeckShearThickness, DeckUnitWeight, ShearStudDia, ShearStudHt, ShearStudFu) 'close ETABS EtabsObject.ApplicationExit(False) 'clean up variables SapModel = Nothing EtabsObject = Nothing End Sub