Retrieves property data for a deck section.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
int GetDeck(
string Name,
ref eDeckType DeckType,
ref eShellType ShellType,
ref string MatProp,
ref double Thickness,
ref int color,
ref string notes,
ref string GUID
)
Function GetDeck ( _
Name As String, _
ByRef DeckType As eDeckType, _
ByRef ShellType As eShellType, _
ByRef MatProp As String, _
ByRef Thickness As Double, _
ByRef color As Integer, _
ByRef notes As String, _
ByRef GUID As String _
) As Integer
int GetDeck(
String^ Name,
eDeckType% DeckType,
eShellType% ShellType,
String^% MatProp,
double% Thickness,
int% color,
String^% notes,
String^% GUID
)
Parameters
- Name
- Type:
System String
The name of an existing deck property.
- DeckType
- Type: ETABS2015 eDeckType
This is one of the items in the eDeckType enumeration.
If this item is Filled, use the GetDeckFilled(String, Double , Double , Double , Double , Double , Double , Double , Double , Double , Double )
function to get additional parameters.
If this item is Unfilled, use the GetDeckUnfilled(String, Double , Double , Double , Double , Double , Double )
function to get additional parameters.
If this item is SolidSlab, use the GetDeckSolidSlab(String, Double , Double , Double , Double )
function to get additional parameters.
- ShellType
- Type: ETABS2015 eShellType
This is one of the items in the eShellType enumeration.
Please note that for deck properties, this is always Membrane
- MatProp
- Type:
System String
The name of the material property for the area property.
This item does not apply when ShellType is Layered.
- Thickness
- Type:
System Double
The membrane thickness. [L]
This item does not apply when ShellType is Layered.
- color
- Type:
System Int32
The display color assigned to the property.
- notes
- Type:
System String
The notes, if any, assigned to the property.
- GUID
- Type:
System String
The GUID (global unique identifier), if any, assigned to the property.
Return Value
The function returns zero if the property data is successfully retrieved;
otherwise it returns a nonzero value.
Imports [Namespace]
Public Sub Example()
Dim SapModel As [Namespace].cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DeckType As ETABS2013.eDeckType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropArea.SetDeck("MyShellProp1A", ETABS2013.eDeckType.Filled, ETABS2013.eShellType.ShellThin, "4000Psi", 14)
ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
Imports [Namespace]
Public Sub Example()
Dim SapModel As [Namespace].cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim DeckType As ETABS2013.eDeckType
Dim ShellType As ETABS2013.eShellType
Dim MatProp As String
Dim Thickness As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
'create ETABS object
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
'start ETABS application
ret = EtabsObject.ApplicationStart()
'create SapModel object
SapModel = EtabsObject.SapModel
'initialize model
ret = SapModel.InitializeNewModel()
'create steel deck template model
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
'set new area property
ret = SapModel.PropArea.SetDeck("MyShellProp1A", ETABS2013.eDeckType.Filled, ETABS2013.eShellType.ShellThin, "4000Psi", 14)
'get area property data
ret = SapModel.PropArea.GetDeck("MyShellProp1A", DeckType, ShellType, MatProp, Thickness, Color, Notes, GUID)
'close ETABS
EtabsObject.ApplicationExit(False)
'clean up variables
SapModel = Nothing
EtabsObject = Nothing
End Sub